Adding Frames

Normally, a Web page fills an entire browser window. However, a browser window can be split into two or more smaller individual panes called frames. Each frame contains an individual Web page.

Frames are used to define areas of a page, such as a navigation bar or a masthead, that remain constant as the user moves through the site. They are also used to define content areas where the content changes each time a navigation link is clicked. Frames allow you to have a site where the navigation part of the window loads only a single time (reducing your bandwidth needs) but the content part of the window changes whenever the user requests a new page.

In this chapter you’ll learn how to create framed layouts, insert individual Web pages into the frames, and manage the navigation for a framed site.

In This Chapter

How Frames Work B1-2
Creating a Frameset B1-5
Using the Frames Panel B1-8
Inserting Pages into Frames B1-14
Saving Framesets and Frames B1-18
Targeting Frames with Links B1-21
Adding noframes Content B1-23
How Frames Work

When you look at a framed site, you are actually seeing multiple pages A. You’ve seen the site in A before, but not in frames. At first glance you might not notice that the site is framed. But once you start scrolling you’ll realize the difference. Notice the scrollbar in A. See how it starts halfway down the side of the page? That’s because there are actually three framed pages shown, and only the frame on the lower right has a scrollbar.

The arrangement of the individual frames is determined by the frameset document. The frameset document contains one or more frameset tags, which set up the number of frames, how they will be arranged, and which individual Web pages will be displayed when the page is opened for the first time.

Exiting the Frame(set)

As detailed in the “Should You Use Frames?” sidebar, frames are on their way out, and Dreamweaver CS6 removes several features found in prior versions that supported frames. You’ll no longer find Frameset options in the Page from Sample tab of the New Document dialog. The Frames button in the Layout category of the Insert panel has been removed. Now, you need to create custom framesets instead of beginning with predefined framed layouts. We’ve updated this chapter to cover the frame features still found in Dreamweaver CS6, but we won’t be surprised to see all frame assistance removed in the next major revision.
No matter how many frames a browser window displays, there is usually only one frameset document for a site. A Web page with three frames actually needs four separate documents to display correctly: the frameset document and the three individual documents that fill the three frames.

A frameset divides a window into either columns or rows, but not both at once. Luckily, framesets can be *nested*, or put one inside another. A frameset of columns can be nested in a row of another frameset. Or, a frameset of rows can be nested in a column of another frameset. In A, the frameset has two rows. The top row holds the site identification. The bottom row splits into two columns with a nested frameset. One column holds the navigation, and the other holds the content. The content frame is the one with the scrollbar.

The frameset document is invisible to the user. It sets up the arrangement of the visible pages shown in the frames. The user sees the results of the frameset document, but not the actual frameset document.

But wait, there’s an accessibility issue. Not all browsers work with framesets. For example, really old browsers didn’t understand frames, and even today, browsers built into mobile devices may have problems with framesets. Therefore, each frameset document contains a `noframes` section. Use the `noframes` section to provide basic information in case the user’s browser cannot display frames. Links to your content pages are an example of good information to include in a `noframes` section. That way every user can find your valuable content.

Dreamweaver lets you set up the frameset and then work on the individual Web pages for the frames separately. Or you can work on the individual Web pages while they are displayed in the frameset. Both are perfectly valid choices; for instance, an individual might manage a site with only a few pages inside the frameset, whereas a larger site might have numerous people handling different content pages.
Should You Use Frames?

Using frames is often a poor choice for layout. Although frames do have some advantages, they’re outweighed by the disadvantages, to the point that few professional or commercial sites now use frames. For every advantage of frames, there are usually ways to achieve the same effect without frames. Because frames are no longer considered to be included in a Web designer’s best practices, we removed this chapter from the paper edition of this book beginning with the CS6 edition. But because some people may still need to work with framed sites, we’ve moved the chapter to the ebook edition and made it separately downloadable for purchasers of the paper edition.

Dreamweaver has many tools for creating framed pages and sites, so it’s important to know that those tools are there if you need them. The most common reason for using frames is navigation. A navigation bar displayed in a frame is always visible no matter how much you scroll in other frames. Some disadvantages of using frames are:

- Not all browsers provide good frame support. Mobile phone browsers and browsers for users with disabilities may have problems with frames. A `noframes` section helps, but it’s a poor substitute for the good browsing experience you hope users have at your site.
- It’s not possible to bookmark framed pages. The URL of a framed page doesn’t appear in the browser’s address bar.
- It’s difficult to get graphic elements to line up precisely between frames.
- Testing the navigation is time consuming.
- Search engines may not be able to properly navigate and index a framed site.
- Visitors who come to your site from search engines will load an unframed page, because search engines will send visitors to your content pages and skip your navigation. Working around that requires some way to get to the “real” version—the content page they want, inside the proper frameset.

Some advantages of using frames are:

- Static frames such as navigation bars or graphical banners don’t have to be reloaded each time the content changes, making your site load faster. But with broadband increasingly available, this argument is much less important than in the past.
- Each frame has its own scrollbar and can be scrolled individually.

Sometimes frames are the best layout choice in spite of their disadvantages. When that is the case, be extra careful to:

- Provide helpful `noframes` content, such as a list (with links) of your content pages. See “Adding noframes Content,” later in this chapter.
- Use the `title` attribute to give each frame a descriptive name. This helps with frame identification and navigation. See “Creating a Frameset” for details.
- Provide a friendly way for visitors arriving from a search engine to get into your framed site. This could be a link to the frameset, or you could use JavaScript to force the user’s browser to load the frameset. There’s no built-in behavior in Dreamweaver to do this, but we cover it in our book *JavaScript: Visual QuickStart Guide* (Peachpit, 2012).
Creating a Frameset

Dreamweaver allows you to create framesets to match the needs of your site. For example, the HomeCook.info site needs a top frame for the masthead, a left frame for the navigation, and a right frame for the changing content.

To make a frameset, you build a custom frameset from scratch by manually drawing frames into a page or choosing some basic frameset layouts from a menu. Dreamweaver gives you the tools to create and resize frames.

To create a frameset:

   The New Document dialog appears.

2. Choose HTML in the Page Type column, and <none> in the Layout column.

3. From the DocType popup menu, choose HTML 4.01 Transitional (frames are deprecated in HTML5, so that’s not a good doctype to use).

4. Click Create.
   A blank page appears.

5. Choose Insert > HTML > Frames, then choose one of the frameset options A.
   Dreamweaver opens the new, framed window, and the Frame Tag Accessibility Attributes dialog appears if you have your Preferences set for frames accessibility B. (You do have Preferences set for frames accessibility, right?)

   continues on next page
In the dialog, select each frame from the Frame pop-up menu and give a descriptive **title** attribute to each frame by typing it into the Title field. When you are done assigning frame titles, click OK.

In 3, we replaced the default suggestion for mainFrame with the more descriptive title “content.” A good **title** for the topFrame is “identification.” A good **title** for the leftFrame is “navigation.” Remember, **title** attributes help users whose browsers can’t display frames understand and navigate your site, so be informative.

or

Choose View > Visual Aids > Frame Borders 6.

This turns on a dotted border around the frame edges. Click and drag the dotted border to insert frames. The cursor changes to a double-headed arrow cursor to drag D.

If you drag from the top or bottom, the document splits horizontally. If you drag from the left or right, the document splits vertically. If you drag from a corner, the document splits into four frames.

The Frame Tag Accessibility Attributes dialog appears. Enter the frame titles, as described above.

---

**TIP** You can also add frames to a frameset by choosing Modify > Frameset > Split Frame Left, Split Frame Right, Split Frame Up, or Split Frame Down.

---

**TIP** You can also add frames to a frameset by choosing Modify > Frameset > Split Frame Left, Split Frame Right, Split Frame Up, or Split Frame Down.
To delete a frame from a frameset:

2. Click and drag the dotted border to the edge of the document window to delete a frame.

   or

   Click the frame border and drag it until it meets another frame border.

**Frame Name vs. Frame Title**

Frame navigation won't work unless you can point to a frame by name. (See “Targeting Frames with Links,” a little later in this chapter.) Every frame needs a name. Dreamweaver assigns a default name based on location or assumed purpose—for example, `topFrame`, `leftFrame`, `mainFrame`.

The *Frame name* displays at the left in the Property inspector when a frame is selected. If you don’t like Dreamweaver’s choice of name, you can type a different one in the Frame name field. If you use a name of your own choosing, there are a few rules:

- No spaces are allowed in a frame name.
- The name must begin with a letter or number.
- It's OK to mix uppercase and lowercase letters.

Frame names work behind the scenes to make the frameset function. They don’t make any difference to your users.

Frame titles, on the other hand, do make a difference to at least some of your users. As we mentioned previously, the *title* attribute provides important identification and navigation help for users with certain types of browsers. Dreamweaver suggests *title* attribute text for you as a prompt in the Frame Tag Accessibility Attributes dialog. This is your one chance to enter *title* information if you work in Design view.

The rules are different for *title* attribute text. More than one word, spaces, and even sentences can go into a *title* attribute. For example, the *title* attribute for the `topFrame` might be something like “Site identification and a link back to the home page.”

Look at the markup for `topFrame` to see where *name* and *title* are used:

```html
<frame src="masthead.html" name="topFrame" scrolling="No" noresize="noresize" id="topFrame" title="site identification and a link back to the home page" />
```

Everything in that code snippet can be modified from the Property inspector except *title*. That’s why you need to grab your chance to write a great blurb for the *title* text when the Frame Tag Accessibility Attributes dialog prompts you for a title. But don’t worry too much if you miss that chance; you can still add and make changes to the *title* text by switching to Code view and editing the code as needed.
Using the Frames Panel

You’ve probably noticed by now that Dreamweaver has a panel for everything. Frames are no exception. If the Frames panel isn’t visible, choose Window > Frames to bring it into view.

It’s a good idea to keep the Frames panel in view when working with a framed site. It gives you a miniature view of the frames within a frameset. It also gives you an easy way to select either an individual frame or an entire frameset.

To select frames and framesets with the Frames panel:

1. In the Frames panel, click the outermost border around the frameset A.
   The selected frameset displays a thick black border.

2. Do one of the following:
   - To select a nested frameset, click the white border around the frameset B.
     The selected frameset displays a thick black border.
     or
   - To select an individual frame, simply click inside the frame C.
     The selected frame displays a black border, thinner than the one used for the frameset.

A thick border indicates the selected frameset.

The nested frameset in the bottom row is outlined with a thick border, indicating that it is selected.

The black border indicates the selected frame. Note that the border for a frame is not quite as thick as the border for a frameset.
When you select a frame in the Frames panel, the corresponding frame is selected in the document window. A dotted border highlights the selected frame in the document window D. The tag selector displays the appropriate element—in this example, it's `<frameset><frame#identification>`.

The dotted border indicates that the nested frameset in the bottom row is selected.

When you select a frameset in the Frames panel, the corresponding frameset is selected in the document window. A dotted border highlights the frameset E. The tag selector displays the appropriate element—in this example, it's `<frameset><frameset>`.
To adjust rows or columns of the frameset:

1. Select the frameset in the Frames panel.
2. Make adjustments with the Property inspector.

The Property inspector displays options for Borders, Border width, and Border color. You can also set either the row height or column width, depending on which is selected. Enter a value, and then choose pixels, percentage, or relative units.

If the selected frameset contains rows, the rows are miniaturized on the Property inspector. The selected row is indicated in dark gray. Clicking a row in this miniature display on the Property inspector selects it. Set the Row Value (that is, the height) for each row as needed.

If the selected frameset contains columns, the columns are miniaturized on the Property inspector. The selected column is indicated in dark gray. Clicking a miniature column in this display on the Property inspector selects it. Set the Column Value (that is, the width) for each column as needed.

![The Property inspector shows a miniature frameset with rows when a frameset with rows is selected. Options to adjust the frameset are displayed.](image)

![The Property inspector with a column frameset selected. You see a miniature frameset indicating which column your adjustments will affect.](image)
Row height and column width can be set in exact units (pixels), as a percentage of the frameset, or as relative. If you choose relative, the row or column takes up whatever space is available. Relative rows and columns can shrink or grow, depending on the size of the browser window. Relative units are considered the most accessible.

As you work with frames, you’ll see that Dreamweaver provides many visual cues, such as dotted borders around selected framesets in the document window and thick borders around selected framesets in the Frames panel. These visual cues are important to watch because it is easy to accidentally change something you don’t intend to change in a complicated frameset if you don’t pay attention to the selected element. These cues also help you make sure you have the right element selected when it is time to save your work. Remember that these visual cues won’t show up in the Web browser.

Selecting a frame or frameset in the Frames panel is not the same as placing an insertion point in a frame by clicking within a frame in the document window.

Turning frame borders on or setting frame border colors in the Property inspector creates a very dated look, and we advise against it, unless you’re shooting for that retro 1996 look.
To adjust frame properties:

1. Select the frame you want in the Frames panel.

2. The Property inspector displays properties for that frame. Make changes in one or more of the properties:

   ▶ Frame name gives a needed identifier to the frame (see the sidebar “Frame Name vs. Frame Title”). Each frame must have a name. If you create a custom frameset, you need to supply the name for the frameset yourself. A name that helps you make sense of your layout, such as `leftFrame`, `navFrame`, or `menuFrame`, is usually what you want here. No spaces are allowed in the name.

   ▶ Src is the URL of the page that initially is displayed in the frameset. Setting this field is covered in “Inserting Pages into Frames.”

Working with Frames and CSS

You won’t use CSS to lay out a framed site, but what about for everything besides layout? CSS works just fine with framed sites to control the various display properties of the individual pages.

In Chapter 9, “Managing Styles,” you learned how to attach a style sheet to a document. To use CSS with a framed site, you simply attach a style sheet to every individual page that will be inserted in your frameset.
If you click inside a frame in the document window, the Property inspector displays the standard text properties for that frame’s document. To change the properties of the frame, use the Frames panel to select the frame.

Monitor size and screen resolution can vary widely among users. Some users must enlarge the text with the browser controls in order to read it. It is a good idea to test your framed site with various browser configurations. Only testing shows you whether scrollbars or resizing are needed so that all your content is viewable.

Size issues can also lead to printing problems in some situations. You may need to provide special printer-friendly pages for a framed site.

One of the reasons that frames got such a bad reputation was due to the tacky look of sites after frame border colors were applied. If you’re considering changing your framed site’s border colors, please reconsider unless you’ve got a darned good reason.

Scroll options are Yes, No, Auto, and Default. Yes means that a scrollbar will always appear regardless of the size of the browser window. No means that particular frame will not have a scrollbar ever, even if not all the contents of the frame are visible. Auto means a scrollbar appears automatically if the contents of the frame are larger than the frame can display. Default is the browser’s default, which is usually Auto. Scrollbars can be horizontal or vertical, depending on which is needed to see all the contents of a frame.

Normally, a frame can be resized in the browser. Selecting the No resize check box means that there will be no way to resize a frame in the browser. If you leave it unselected, users can drag the frame borders in the browser window. This is useful for users who prefer to have especially small or especially large browser windows.

Margin width and Margin height refer to the margin surrounding an individual frame.

Borders, which can be set at the frameset level, can also be set individually for each frame. The choices are Default (the browser default, which is usually No), Yes, and No.

Border color allows you to set the color for the frame borders. Click the color well to bring up a color picker to help you set the color.
Inserting Pages into Frames

Now that you’ve got your frames set up, you’ll need to create pages to fill every frame. These pages are normal Web pages in every way except that they contain just a part of what appears in the overall window. To prepare the HomeCook.info example, it took four individual pages: `masthead.html`, `menu.html`, `home.html`, and the frameset document. 

This individual HTML page will be placed in the **identification** frame of the frameset.
This individual HTML page will be placed in the **navigation** frame of the frameset.

This individual HTML page will be placed in the **content** frame of the frameset.
To add a prepared page to a frame:

1. Click anywhere in the frame.
2. Choose File > Open in Frame.
   The Select HTML File dialog appears.
3. Browse to select the file you want to insert, and then click OK (Choose).
4. Repeat the steps to add files to other frames.
5. When every frame has its opening file, choose File > Save Frameset.
   The inserted files are now the Src documents for the various frames in the frameset.
   For more about saving framesets, see “Saving Framesets and Frames.”

TIP Naming a “home” page is slightly different with framed sites. You’d normally name the home page index.html. But in a framed site, you need that filename for the frameset. With a framed site, think of the initial set of files displayed when the frameset opens as Home. The page in C is named home.html because it’s in the opening content frame before any links are clicked.

The identification and navigation frames have files inserted, but the content frame is still unfilled.
To add content to a page in a frame:

1. Click anywhere in the frame.

2. Insert text and images with your normal Web content creation verve. If you need a refresher, take a peek at Chapter 3, “Building Your First Page” or Chapter 4, “Adding Text to Your Pages.”

3. Choose File > Save Frame.
   For more about saving frames, see “Saving Framesets and Frames,” later in this chapter.

You can type or insert material in a framed file while it is part of the frameset.
Saving Framesets and Frames

As soon as you create a frameset, it’s selected in the document window. But if you’ve been working with frames and files, it can get tricky to know just what file you’re working on. Sometimes the option to save what you want is grayed out. This could mean that the file was already saved. If you know it wasn’t, recheck all the visual clues to figure out what you have selected. Be sure you have the frame or frameset you intend to save selected.

To save a frameset:

1. To select the frameset, click the outer border of the frameset in the Frames panel.
   
   The thick border indicates the selected frameset (as in figure A in “Using the Frames Panel,” earlier in this chapter).

2. Choose File > Save Frameset.
   
   If the frameset document has never been saved before, you’ll be prompted to name the file. The frameset document is the file that is opened when a visitor first arrives at a URL, so frameset files are often saved as index.html.

   or

   Choose File > Save All.
   
   This saves the frameset and all other open files at once. If this is the first time you are saving the files, Dreamweaver prompts you to name each file prior to saving it.

   or

   Choose File > Save Frameset As.
   
   This prompts you to save the frameset with a different name from the one you might already be using, and it is useful for making a backup or saving a copy.

Working with iframes

An iframe is an inline frame or an inline subwindow. In much the same way that you can insert an image into a page of text, you can insert an iframe. The iframe element inserts an entire miniature view of an HTML page into another page. This is handy when you want some small bit of content to come from somewhere else, in a page that otherwise isn’t framed. For instance, those ubiquitous Google AdSense ads you see on many sites are done with iframes.

Dreamweaver is only minimally equipped to create iframes fresh out of the box, but you can get an extension to add more capabilities. For instance, one named iFrame Suite contains five extensions for working with iframes. It, along with other extensions related to iframes, is available at the Adobe Exchange at www.adobe.com. If you’d like more information on installing and using extensions, refer to Appendix B, “Customizing and Extending Dreamweaver.”
To save a frame:

1. Click anywhere in an individual frame.
2. Several File menu options related to frames are now available:
   - Choose File > Save Frame to save the currently selected frame.
   - Choose File > Save Frame As to save the current frame with a different name.
   - Choose File > Save Frame As Template. This creates a template you can use to create similar pages (see Chapter 16, “Making Life Easier: Using Templates, Libraries, and Snippets”).

TIP If you’re working on an internal content page of your site while typing in a frame in the frameset document window, be careful when you save. You want to save only the file in the frame, not the entire frameset. If you inadvertently save the frameset, you’ll be accidentally changing the Src file in the frameset document to that of the file you just saved—probably not what you wanted. Make sure that you’re saving the frame file, not the frameset file.

TIP Double-check the document window to verify that the frameset or frame you want to save is what’s selected. Dotted borders outline the selected frameset A. In the figure, because the selected frame is inside a nested frameset, the tag selector at the bottom of the window displays `<frameset>` <frameset><frameset><frame#navFrame>`.

A Check for the dotted lines indicating a selection to be sure about what you are saving.
Page Title and Frame Title

Every document you create in Dreamweaver has a Title field in the toolbar at the top of the document window. The frameset page title may be the only title a user ever sees for your framed site, so make it count. However, it’s a good idea to give each document in the site a title, too.

We need a little semantic clarification here, because there are title elements, and then there are title attributes. You first heard about title elements in Chapter 3. There you learned how to create the document title in the Title field at the top of the window. This is the title that appears in the title bar of a Web browser when the page is loaded.

In this chapter, we talk a lot about title attributes for frames. Now, title attributes are very important, but they’re not the same thing as the title elements that give a document a title.

Attributes modify elements. An element is made with an HTML tag. If you wrap some text with an HTML tag, you’ve got an element. HTML elements are things like paragraphs, lists, images, headings, and frames. All those elements have attributes like size, color, border, margin, and possibly title. A title attribute lets you set some characteristic of an element. In this chapter, a title attribute adds information to its frame element.

If all this semantic talk is too much for you, just remember this: if Dreamweaver gives you a chance to put a title anywhere, do it!
You probably surfed the Web for all of a minute and a half before you first realized that if you click a link, the current page goes away and a new page fills the window. That's a great system—except for framed sites. Often, when a link is clicked in one frame, the new file should open in some other frame entirely. You can make that happen by using a target attribute in the link. The target names the frame where the new file will open. Yep, that's why you named the frames.

**To make a target link while working in the frameset:**

1. Open the frameset with the page where you want the link visible.
2. Highlight the text for the link.
3. The Property inspector link options appear.
   - Browse for the file you want the link to open.
   - or
   - Click the Point to File icon and point to a file in the Files panel to create the link.
   - Choose the target frame from the Target menu. Dreamweaver already knows which frames are in the frameset.
4. Choose Save > Frame to save your changes.
To make a target link while working on an individual page:

1. Open the page where the link will be.
2. Highlight the text for the link.
3. The Property inspector link options appear.
   - Browse for the file you want the link to open.
   - or
   - Click the Point to File icon and point to a file in the Files panel to create the link.
   - Type the frame name in the Target field. Spelling and capitalization of the frame name must be exactly right.
4. Save your changes.

**Tip** Although it's definitely handy to have the pop-up menu of frame targets right there in the Property inspector when making links in the frameset document window, it's not without peril. Inadvertent improper saves can play havoc with the frameset. If you create the individual pages for the site independently, outside of the frameset document, you do have to do a bit of extra typing to get the Target field filled in. However, when you save an individual page, you can't possibly save anything besides the individual page.

When you create a link in an individual document, you must manually type the target in the Target field of the Property inspector.
Adding noframes Content

Some wireless users who access the Web with mobile phones, tablets, or other small devices can’t view frames—nor can users with disabilities who have specialized browsers. These folks need noframes content—unless you want them all to go away and leave your site alone, never to return.

The content in a noframes element could be an entire alternate Web page, providing all the information a frames-capable user would find in the framed site. A less ambitious noframes element might contain an invitation for the user to click through to a site navigation page or a site index page so that the content you offer could still be accessed.

Search engines also sometimes make use of noframes content. Use it to describe the site’s key information and provide links for the search engine robots (or other users) to follow.
To add noframes content:

1. Select the frameset in the Frames panel.

2. Choose Modify > Frameset > Edit NoFrames Content A.

3. A blank page appears in the document window, replacing the framed pages B. Type or paste the noframes content in this blank window C.

4. To return to the frameset, choose Modify > Frameset > Edit NoFrames Content again.

TIP If you preview your site in a regular browser (which has no trouble displaying frames), you won’t see the noframes content.

A To set what will be displayed for non-frames-supporting browsers, choose Edit NoFrames Content from the Frameset submenu of the Modify menu.

B The Edit NoFrames Content command brings up an empty NoFrames Content document.

C Site information and links are added to the NoFrames Content document.